OMF:BG Message Board Forum Index OMF:BG Message Board
One Must Fall: Battlegrounds
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

[2097] Crashes on performing Specials

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    OMF:BG Message Board Forum Index -> Retail Bug Support
View previous topic :: View next topic  
Author Message
Kal_Zakath13



Joined: 17 Aug 2003
Posts: 23
Location: Canada

PostPosted: Mon Jan 05, 2004 9:32 am    Post subject: [2097] Crashes on performing Specials Reply with quote

Ok. Installed, patched, Load the game.
Wanting to test the new bots, I try Chronos first.
Try Training and Practice Arenas, just to see the cool attacks. After performing a Create Time-Acceleration Crystal attack (1st action), I throw the crystal, and just as it's about to hit, the game crashes to desktop. Not even an error message.

Load game again. This time, I can create the crystal, throw it and hit, but when I try to do a Super Acceleration Crystals attack it crashes.

Load game again. Turn off all effects and run at minimum resolution.
Restart game. Try again... Crash.

Load game again. Try Gargoyle. Seems to work fine (effects still turned off)

Turn effects back on (except bump-mapping, which results in a purple glow around everything), raise resolution back to 1024x768 32bpp.

Restart Game. Try as Gargoyle again. Seems to work fine.

Try Katana. Try Rising Blade. Crash.

Possible helpful info: Just before performing a special for the first time, the game seems to slow down, but I think it's just loading effects into Cache or Ram, as it doesn't do it the next time I perform the attack. It slows right down again before giving up and crashing.

I could keep doing all the bots, but It's not very exciting to do. I had the problem briefly in the limited test, but it went away, so I thought the problem was fixed.

Anyways, I hope all my describing seems to help. PC Specs in Sig. If more info is needed, let me know.
_________________
PC Specs:
Processor: AMD Duron 900Mhz
Motherboard: QDI KinetiZ 7E-A
RAM: 256MB PC/133
Video: 128MB MSI GeForceFX 5600 (Driver: 5214)
Sound: Voyetra Turtle Beach Santa Cruz (Driver: 4161)
O/S: WinXP Pro (SP1, Dx9.0b)
HD Space: C: 40GB, D: 120GB (Installed on DSmile
Internet: DSL
Anything Else: Shouldn't be important.
If it is, I'll add it.
Back to top
View user's profile Send private message
Kevin Byrd



Joined: 05 Feb 2003
Posts: 494

PostPosted: Mon Jan 05, 2004 9:49 am    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

We are testing a patch right now that should adress several crash and memory leak errors so hang in there for today and we will see whats goin on after the next patch.

Thanks for providing such detailed reports. I know of a couple of things that have been fixed that may be causing those issues for you but as we say "until it is tested it doesn't work", so we'll have to see with the next patch.
_________________
[/b]!I fear no spoofed e-mails![/b]
Back to top
View user's profile Send private message Visit poster's website
Marks



Joined: 21 Jun 2003
Posts: 693
Location: Umea, Sweden

PostPosted: Mon Jan 05, 2004 10:49 am    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Ok, this is a longshot but your descriptions of crashes, are very similar to what I've been experiencing with the game. The game always crashed when performing a special or during a longer combo. I noticed that we share sound properties:

Sound: Voyetra Turtle Beach Santa Cruz (Driver: 4161)

My issues were solved, when I turned off the sound and I've been playing like that for months without a problem.

Yesterday I tested the pre-release patch (2100) and I thought it was going to fix this. At first it seemed much more stable but when more players were added, the game started to crash just like it used to do. It gave me a much more detailed error message though, which obviously shows that it was indeed an audio error.

Quote:
====== BEGIN Diversions Ent. NOTIFICATION DUMP ======
Time: Mon Jan 05 12:40:25 2004

Type: Fatal Error
Name: DirectAudio error
Description: An invalid parameter was passed to the returning function. Please ensure that you have updated drivers, as well as the newest operating system updates. For additional assistance or more information about required hardware, visit support.omf.com.

Application will now Exit!
File Name: Q:\DIVERSIONS\Engine\OSWindows\AudioPlayer\DirectX\DirectXNoiseElements.cpp
Line Number: 257

====== END Diversions Ent. NOTIFICATION DUMP ======


The only problem with this message is that 4161 are the latest drivers for santa cruz and I already have all the system updates and directx that are available. But I didn't give up. Today I made a rollback to driver v4081 and this seem to have fixed the crashes completely. I played for a few hours, through some tournaments with sounds on all the time and I didn't experience any crash at all.

Just to check if you got the same problem as I had, try to disable the sound. If that fixes it, there is always the option to rollback to an older driver like I did. :thumbsup:
_________________
Fury Talon: Website | Message Board
Back to top
View user's profile Send private message
Kevin Byrd



Joined: 05 Feb 2003
Posts: 494

PostPosted: Mon Jan 05, 2004 1:12 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

OK you can patch again to 2101. It is still a test retail patch but with this error you posted it would be great if you could auto-update to 2101 and test with sound on to see if it fixes this issue for you.

Right now we really need testing of that 2101 patch and the beta testers don't seem to be online so if anyone reading this doesn't mind risking a re-install of OMF if this patch is not made retail, then please update to the 2101 test patch.

And leave feedback in this forum with "2101 test patch results" as the post subject.

Thanks alot peeps.
_________________
[/b]!I fear no spoofed e-mails![/b]
Back to top
View user's profile Send private message Visit poster's website
Kal_Zakath13



Joined: 17 Aug 2003
Posts: 23
Location: Canada

PostPosted: Mon Jan 05, 2004 4:24 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Thanks Markster. You seemed to hit it right on the head. I always thought the problem was with the video card, as I upgraded it a few months back, and then my Limited Test wouldn't work. That problem was fixed (or maybe it was the same one that just didn't appear as often), but it seems that the sound is the problem now.

I turned off my sound, played as Chronos, then as Katana, and as soon as I turned on my sound and went to hit the training bot with a Rising Blade, it kicked me out.

I'm downloading the Limited Test again, as I erased it when I bought the game, and will try the new patch and give appropriate feedback. Thanks for the great response!
_________________
PC Specs:
Processor: AMD Duron 900Mhz
Motherboard: QDI KinetiZ 7E-A
RAM: 256MB PC/133
Video: 128MB MSI GeForceFX 5600 (Driver: 5214)
Sound: Voyetra Turtle Beach Santa Cruz (Driver: 4161)
O/S: WinXP Pro (SP1, Dx9.0b)
HD Space: C: 40GB, D: 120GB (Installed on DSmile
Internet: DSL
Anything Else: Shouldn't be important.
If it is, I'll add it.
Back to top
View user's profile Send private message
Marks



Joined: 21 Jun 2003
Posts: 693
Location: Umea, Sweden

PostPosted: Mon Jan 05, 2004 4:56 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Ok, I played around with build 2101 all night and I got both bad and good news. Bad news is that this build still crashes with drivers 4161.

Good news is that there are infact even newer drivers (4193) available at Turtle Beach. I've checked that site a thousand times and it's not until now I noticed the drivers. :sweat2: Unfortunatly, I couldn't get the drivers to install properly on my machine, so I have to stick around with 4081. That's not a bad thing, because those old drivers work very well with this build.

Kal_Zakath13: There is a possibility that the new drivers 4193, will work aswell. I suggest that you download them right away and then report back whether it works better or not.
_________________
Fury Talon: Website | Message Board
Back to top
View user's profile Send private message
Kal_Zakath13



Joined: 17 Aug 2003
Posts: 23
Location: Canada

PostPosted: Mon Jan 05, 2004 7:13 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Well well. I actually had these drivers before (remembering that I had installed the unsigned drivers in the past), but after flattening my computer a few months ago, I must not have kept the 4193 drivers on my backup disc, so installed 4161 again. Anyways... After installing the new drivers, and re-booting the computer. OMF:BG now works Perfectly!!! Yay!!

Side note: While after installing the new sound card drivers, the sound works fine, the game will still crash unless the computer is restarted. If you are having trouble installing the new drivers, make sure you completely uninstall the old ones first.

Thanks for the tip! It solved my problem. Now, the only thing is that the sound seems to be kind of quiet, but it usually is if it's using EAX or some other form of 3D Sound. Music is fine, just the sound effects. I've just turned down the music to about 30, and the sound is audible again.
_________________
PC Specs:
Processor: AMD Duron 900Mhz
Motherboard: QDI KinetiZ 7E-A
RAM: 256MB PC/133
Video: 128MB MSI GeForceFX 5600 (Driver: 5214)
Sound: Voyetra Turtle Beach Santa Cruz (Driver: 4161)
O/S: WinXP Pro (SP1, Dx9.0b)
HD Space: C: 40GB, D: 120GB (Installed on DSmile
Internet: DSL
Anything Else: Shouldn't be important.
If it is, I'll add it.
Back to top
View user's profile Send private message
Kevin Byrd



Joined: 05 Feb 2003
Posts: 494

PostPosted: Mon Jan 05, 2004 10:43 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Kal-

Are you saying that you are still getting a crash when you try to run the game twice in a row?
_________________
[/b]!I fear no spoofed e-mails![/b]
Back to top
View user's profile Send private message Visit poster's website
Kal_Zakath13



Joined: 17 Aug 2003
Posts: 23
Location: Canada

PostPosted: Tue Jan 06, 2004 11:10 am    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

No. I've never had that problem. The only problem I had was with the sound card. Apperently, their "beta" (Release Candidate, Unsigned) version of the newest sound card drivers fixed the problem I was having.

I now have no problems with OMF, at least as far as I've gotten. I haven't really had much chance to play the tournaments yet, so I've just been in the training level playing with the new bots and getting their Special Attacks down. It's never crashed because of running the game twice, as far as I know.

My note about it crashing after installing the new drivers was because I hadn't re-booted my computer after installing the new drivers, so I don't think the new drivers were fully loaded then. Once the computer re-booted, the game seems to run perfectly.

I'll let you know if I run into any more problems, but probably as a new post, as this problem seems to be solved.
_________________
PC Specs:
Processor: AMD Duron 900Mhz
Motherboard: QDI KinetiZ 7E-A
RAM: 256MB PC/133
Video: 128MB MSI GeForceFX 5600 (Driver: 5214)
Sound: Voyetra Turtle Beach Santa Cruz (Driver: 4161)
O/S: WinXP Pro (SP1, Dx9.0b)
HD Space: C: 40GB, D: 120GB (Installed on DSmile
Internet: DSL
Anything Else: Shouldn't be important.
If it is, I'll add it.
Back to top
View user's profile Send private message
Kal_Zakath13



Joined: 17 Aug 2003
Posts: 23
Location: Canada

PostPosted: Tue Jan 06, 2004 12:22 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Well, it was working yesterday, but then I just put the disc in to play again, the game patched itself to 2101, and the same crash occured, this time though, I got an error message box. It says

"DirectAudio error"
"An invalid parameter was passed to the returning function. Please insure that you have updated drivers, as well as the newest operating system updates. For additional assistance or more information about required hardware, visit support.omf.com.

Application will now Exit!"

Well, at least I got an error this time. Same problem as Markster though. I'm using the newest drivers for all my stuff, including the sound card (which was just updated yesterday), and all the Windows updates, so the error isn't very helpful, except to tell me to play without sound. I might just have to roll back to the old drivers, and play with those, although I never like rolling back to older drivers.
_________________
PC Specs:
Processor: AMD Duron 900Mhz
Motherboard: QDI KinetiZ 7E-A
RAM: 256MB PC/133
Video: 128MB MSI GeForceFX 5600 (Driver: 5214)
Sound: Voyetra Turtle Beach Santa Cruz (Driver: 4161)
O/S: WinXP Pro (SP1, Dx9.0b)
HD Space: C: 40GB, D: 120GB (Installed on DSmile
Internet: DSL
Anything Else: Shouldn't be important.
If it is, I'll add it.
Back to top
View user's profile Send private message
Marks



Joined: 21 Jun 2003
Posts: 693
Location: Umea, Sweden

PostPosted: Tue Jan 06, 2004 1:21 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Weird. As I said, 4081 works fine. There may be other drivers in between that work aswell, I just don't think it is exciting to test which do work and which do not. Smile

I know this wasn't a problem when Limited Test came. But when new sound effects were added at one point, the game just started to crash afterwards.

I've updated my thread in LT forums to reflect this build. Crash message and dx dumps are included.
_________________
Fury Talon: Website | Message Board
Back to top
View user's profile Send private message
Indomitable



Joined: 04 Aug 2003
Posts: 11
Location: USA. Illinois

PostPosted: Sun Jan 11, 2004 3:55 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

I have the crash message with the the same game scenerios. Can you link me to the older Santa Cruz drivers please?
Back to top
View user's profile Send private message
Marks



Joined: 21 Jun 2003
Posts: 693
Location: Umea, Sweden

PostPosted: Sun Jan 11, 2004 4:52 pm    Post subject: Re: [2097] Crashes on performing Specials Reply with quote

Hmm. looks like Turtle Beach doesn't have anything older than 4161 intended for Win2K/XP, on their site.

Sorry, but I only have drivers for Dell systems so I doubt that will be of any help for you, that is if you are not running Dell yourself. There must be another way to get a hold of the drivers though. They are retail drivers, so I guess they must be present on either a Windows CD, or on an install disc for Santa Cruz. That's about the best info I could offer.
_________________
Fury Talon: Website | Message Board
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    OMF:BG Message Board Forum Index -> Retail Bug Support All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

Style Blacker1 by Blacker47